<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Patti LaBelle Returning to Mohegan Sun May 3 | What&#039;s Up Rhode Island</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://whatsuprhodeisland.com/xmlrpc.php" />
    <meta property="og:image" content="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-scaled.jpeg" /><link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="What&#039;s Up Rhode Island &raquo; Feed" href="https://whatsuprhodeisland.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="What&#039;s Up Rhode Island &raquo; Comments Feed" href="https://whatsuprhodeisland.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="What&#039;s Up Rhode Island &raquo; Patti LaBelle Returning to Mohegan Sun May 3 Comments Feed" href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whatsuprhodeisland.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
			//@formatter:off
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://whatsuprhodeisland.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Poll-css'  href='https://whatsuprhodeisland.com/wp-content/plugins/poll-wp/CSS/Total-Soft-Poll-Widget.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://whatsuprhodeisland.com/wp-content/plugins/poll-wp/CSS/totalsoft.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://whatsuprhodeisland.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://whatsuprhodeisland.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://whatsuprhodeisland.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=9e241c87ee8782e8f19bb886a935e653' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://whatsuprhodeisland.com/wp-content/themes/Newspaper/style.css?ver=9.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://whatsuprhodeisland.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=4dea8d5b26348370b86f315beb853d86' type='text/css' media='all' />
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var object = {"ajaxurl":"https:\/\/whatsuprhodeisland.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-content/plugins/poll-wp/JS/Total-Soft-Poll-Widget.js?ver=5.3.2'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5b772246d6248b00118037e8'></script>
<link rel='https://api.w.org/' href='https://whatsuprhodeisland.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://whatsuprhodeisland.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://whatsuprhodeisland.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds' href='https://whatsuprhodeisland.com/2020/01/legislative-news-jan-13-state-of-the-state-address-arming-campus-police-school-district-raising-funds/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/" />
<link rel='shortlink' href='https://whatsuprhodeisland.com/?p=12150' />
<link rel="alternate" type="application/json+oembed" href="https://whatsuprhodeisland.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whatsuprhodeisland.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F&#038;format=xml" />
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/whatsuprhodeisland.com\/wp-admin\/","wpRestNonce":"265e23f106","wpRestUrl":"https:\/\/whatsuprhodeisland.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>
    
.block-title > span,
    .block-title > span > a,
    .block-title > a,
    .block-title > label,
    .widgettitle,
    .widgettitle:after,
    .td-trending-now-title,
    .td-trending-now-wrapper:hover .td-trending-now-title,
    .wpb_tabs li.ui-tabs-active a,
    .wpb_tabs li:hover a,
    .vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab.vc_active > a,
    .vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container .vc_tta-tab:hover > a,
    .td_block_template_1 .td-related-title .td-cur-simple-item,
    .woocommerce .product .products h2:not(.woocommerce-loop-product__title),
    .td-subcat-filter .td-subcat-dropdown:hover .td-subcat-more,
    .td-weather-information:before,
    .td-weather-week:before,
    .td_block_exchange .td-exchange-header:before,
    .td-theme-wrap .td_block_template_3 .td-block-title > *,
    .td-theme-wrap .td_block_template_4 .td-block-title > *,
    .td-theme-wrap .td_block_template_7 .td-block-title > *,
    .td-theme-wrap .td_block_template_9 .td-block-title:after,
    .td-theme-wrap .td_block_template_10 .td-block-title::before,
    .td-theme-wrap .td_block_template_11 .td-block-title::before,
    .td-theme-wrap .td_block_template_11 .td-block-title::after,
    .td-theme-wrap .td_block_template_14 .td-block-title,
    .td-theme-wrap .td_block_template_15 .td-block-title:before,
    .td-theme-wrap .td_block_template_17 .td-block-title:before {
        background-color: #222222;
    }

    .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
    	background-color: #222222 !important;
    }

    .block-title,
    .td_block_template_1 .td-related-title,
    .wpb_tabs .wpb_tabs_nav,
    .vc_tta-container .vc_tta-color-grey.vc_tta-tabs-position-top.vc_tta-style-classic .vc_tta-tabs-container,
    .woocommerce div.product .woocommerce-tabs ul.tabs:before,
    .td-theme-wrap .td_block_template_5 .td-block-title > *,
    .td-theme-wrap .td_block_template_17 .td-block-title,
    .td-theme-wrap .td_block_template_17 .td-block-title::before {
        border-color: #222222;
    }

    .td-theme-wrap .td_block_template_4 .td-block-title > *:before,
    .td-theme-wrap .td_block_template_17 .td-block-title::after {
        border-color: #222222 transparent transparent transparent;
    }
    
    .td-theme-wrap .td_block_template_4 .td-related-title .td-cur-simple-item:before {
        border-color: #222222 transparent transparent transparent !important;
    }

    
    .td-footer-wrapper,
    .td-footer-wrapper .td_block_template_7 .td-block-title > *,
    .td-footer-wrapper .td_block_template_17 .td-block-title,
    .td-footer-wrapper .td-block-title-wrap .td-wrapper-pulldown-filter {
        background-color: #111111;
    }

    
    .td-footer-wrapper::before {
        background-image: url('https://whatsuprhodeisland.com/wp-content/uploads/2017/07/providence.jpg');
    }

    
    .td-footer-wrapper::before {
        background-size: cover;
    }

    
    .td-footer-wrapper::before {
        background-position: center center;
    }

    
    .td-footer-wrapper::before {
        opacity: 0.1;
    }
</style>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://whatsuprhodeisland.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://whatsuprhodeisland.com/category/arts/",
                                "name": "Arts &amp; Culture"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/",
                                "name": "Patti LaBelle Returning to Mohegan Sun May 3"                                
                            }
                        }    ]
                        }
                       </script><link rel="icon" href="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/cropped-whatsupri-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/cropped-whatsupri-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/cropped-whatsupri-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/cropped-whatsupri-270x270.jpg" />

<!-- Button style compiled by theme -->

<style>
    
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-12150 single-format-standard patti-labelle-returning-to-mohegan-sun-may-3 global-block-template-8 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/whatsuprhodeisland/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.instagram.com/whatsuprhodeisland" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.twitter.com/whats_up_ri" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-2715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-2715"><a href="https://whatsuprhodeisland.com">Home</a></li>
<li id="menu-item-6697" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6697"><a href="https://whatsuprhodeisland.com/category/news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-11336" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11336"><a href="https://whatsuprhodeisland.com/2019/12/school-and-business-closings-in-rhode-island-and-southeastern-massachusetts/">School and Business Closings in Rhode Island and Southeastern Massachusetts</a></li>
</ul>
</li>
<li id="menu-item-12042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12042"><a href="https://whatsuprhodeisland.com/category/business/">Business</a></li>
<li id="menu-item-6690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6690"><a href="https://whatsuprhodeisland.com/category/restaurants/">Food &#038; Drink</a></li>
<li id="menu-item-12045" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12045"><a href="https://whatsuprhodeisland.com/category/government-politics/">Government &#038; Politics</a></li>
<li id="menu-item-1642" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1642"><a href="https://whatsuprhodeisland.com/events-calendar/">Events Calendar</a></li>
<li id="menu-item-6692" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6692"><a href="https://whatsuprhodeisland.com/category/things-to-do/">Things To Do<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-6684" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6684"><a href="https://whatsuprhodeisland.com/category/arts/">Arts &#038; Entertainment</a></li>
	<li id="menu-item-6685" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6685"><a href="https://whatsuprhodeisland.com/category/entertainment-music/">Entertainment &#038; Music</a></li>
	<li id="menu-item-6689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6689"><a href="https://whatsuprhodeisland.com/category/sports/">Health &#038; Fitness</a></li>
	<li id="menu-item-6686" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6686"><a href="https://whatsuprhodeisland.com/category/entertainment-music/movies/">Movies</a></li>
	<li id="menu-item-6693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6693"><a href="https://whatsuprhodeisland.com/category/outdoor-recreation/">Outdoor &#038; Recreation</a></li>
	<li id="menu-item-6687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6687"><a href="https://whatsuprhodeisland.com/category/entertainment-music/photo-gallery/">Photo Gallery</a></li>
	<li id="menu-item-6688" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6688"><a href="https://whatsuprhodeisland.com/category/entertainment-music/review/">Reviews</a></li>
	<li id="menu-item-6691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6691"><a href="https://whatsuprhodeisland.com/category/entertainment-music/theatre/">Theatre</a></li>
</ul>
</li>
<li id="menu-item-6698" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6698"><a href="https://whatsuprhodeisland.com/category/people-profiles/">People &#038; Profiles<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-6699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6699"><a href="https://whatsuprhodeisland.com/category/people-profiles/interview/">Interviews</a></li>
	<li id="menu-item-6700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6700"><a href="https://whatsuprhodeisland.com/category/people-profiles/podcasts/">Podcasts</a></li>
</ul>
</li>
<li id="menu-item-2720" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2720"><a href="https://whatsuprhodeisland.com/category/real-estate/">Real Estate</a></li>
<li id="menu-item-7433" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7433"><a href="https://whatsuprhodeisland.com/sports/">Sports</a></li>
<li id="menu-item-9840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9840"><a href="http://www.whatsuprhodeisland.com">What&#8217;s Up<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-9241" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9241"><a href="https://whatsuprhodeisland.com/about-whatsuprhodeisland/">About Us</a></li>
	<li id="menu-item-9243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9243"><a href="https://whatsuprhodeisland.com/advertise-with-us/">Advertise With Us</a></li>
	<li id="menu-item-9242" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9242"><a href="https://whatsuprhodeisland.com/sign-up-for-our-email-newsletters/">Sign Up For Our Email Newsletters</a></li>
	<li id="menu-item-9245" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9245"><a href="http://www.whatsupnewp.com">What&#8217;s Up Newp</a></li>
	<li id="menu-item-10584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10584"><a href="http://www.whatsupstowe.com">What&#8217;s Up Stowe</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://whatsuprhodeisland.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-mp-1">
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/whatsuprhodeisland/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.instagram.com/whatsuprhodeisland" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.twitter.com/whats_up_ri" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>        
<div class="td-header-sp-top-menu">


	<!-- td weather source: cache -->		<div class="td-weather-top-widget" id="td_top_weather_uid">
			<i class="td-icons clear-sky-d"></i>
			<div class="td-weather-now" data-block-uid="td_top_weather_uid">
				<span class="td-big-degrees">36.1</span>
				<span class="td-weather-unit">F</span>
			</div>
			<div class="td-weather-header">
				<div class="td-weather-city">Providence</div>
			</div>
		</div>
		        <div class="td_data_time">
            <div >

                Tuesday, January 14, 2020
            </div>
        </div>
    </div>



            </div>

<!-- LOGIN MODAL -->
            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<div class="td-logo-text-wrap">
			<span class="td-logo-text-container">
				<a class="td-logo-wrap" href="https://whatsuprhodeisland.com/">
											<span class="td-logo-text">Whats Up Rhode Island</span>
										<span class="td-tagline-text"> Local, independent news and information for Rhode Island and beyond.</span>
				</a>
			</span>
		</div>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-2715"><a href="https://whatsuprhodeisland.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6697"><a href="https://whatsuprhodeisland.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11336"><a href="https://whatsuprhodeisland.com/2019/12/school-and-business-closings-in-rhode-island-and-southeastern-massachusetts/">School and Business Closings in Rhode Island and Southeastern Massachusetts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12042"><a href="https://whatsuprhodeisland.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6690"><a href="https://whatsuprhodeisland.com/category/restaurants/">Food &#038; Drink</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12045"><a href="https://whatsuprhodeisland.com/category/government-politics/">Government &#038; Politics</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1642"><a href="https://whatsuprhodeisland.com/events-calendar/">Events Calendar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6692"><a href="https://whatsuprhodeisland.com/category/things-to-do/">Things To Do</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-6684"><a href="https://whatsuprhodeisland.com/category/arts/">Arts &#038; Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-6685"><a href="https://whatsuprhodeisland.com/category/entertainment-music/">Entertainment &#038; Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6689"><a href="https://whatsuprhodeisland.com/category/sports/">Health &#038; Fitness</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6686"><a href="https://whatsuprhodeisland.com/category/entertainment-music/movies/">Movies</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6693"><a href="https://whatsuprhodeisland.com/category/outdoor-recreation/">Outdoor &#038; Recreation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6687"><a href="https://whatsuprhodeisland.com/category/entertainment-music/photo-gallery/">Photo Gallery</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6688"><a href="https://whatsuprhodeisland.com/category/entertainment-music/review/">Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6691"><a href="https://whatsuprhodeisland.com/category/entertainment-music/theatre/">Theatre</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6698"><a href="https://whatsuprhodeisland.com/category/people-profiles/">People &#038; Profiles</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6699"><a href="https://whatsuprhodeisland.com/category/people-profiles/interview/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6700"><a href="https://whatsuprhodeisland.com/category/people-profiles/podcasts/">Podcasts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2720"><a href="https://whatsuprhodeisland.com/category/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-7433"><a href="https://whatsuprhodeisland.com/sports/">Sports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-9840"><a href="http://www.whatsuprhodeisland.com">What&#8217;s Up</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9241"><a href="https://whatsuprhodeisland.com/about-whatsuprhodeisland/">About Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9243"><a href="https://whatsuprhodeisland.com/advertise-with-us/">Advertise With Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9242"><a href="https://whatsuprhodeisland.com/sign-up-for-our-email-newsletters/">Sign Up For Our Email Newsletters</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-9245"><a href="http://www.whatsupnewp.com">What&#8217;s Up Newp</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10584"><a href="http://www.whatsupstowe.com">What&#8217;s Up Stowe</a></li>
</ul>
</li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://whatsuprhodeisland.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

            <div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5e1de2616e86e_rand td_block_template_8"><div class="td-all-devices"> <div class="whats-manual-1" id="whats-121518073"><p><a href="https://www.durisstudios.com/"><img class="aligncenter size-full wp-image-12016" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-2.jpg" alt="" width="640" height="79" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-2.jpg 640w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-2-600x74.jpg 600w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-2-150x19.jpg 150w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
</div> </div></div>
</div>                </div>
            </div>
        </div>
    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://whatsuprhodeisland.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Arts &amp;amp; Culture" class="entry-crumb" href="https://whatsuprhodeisland.com/category/arts/">Arts &amp; Culture</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Patti LaBelle Returning to Mohegan Sun May 3</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-12150" class="post-12150 post type-post status-publish format-standard has-post-thumbnail category-arts category-entertainment-music tag-mohegan-sun tag-patti-labelle" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://whatsuprhodeisland.com/category/arts/">Arts &amp; Culture</a></li><li class="entry-category"><a  href="https://whatsuprhodeisland.com/category/entertainment-music/">Entertainment &amp; Music</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Patti LaBelle Returning to Mohegan Sun May 3</h1>

                                    <p class="td-post-sub-title">Tickets on sale Friday, January 17th</p>
                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://whatsuprhodeisland.com/author/whats-up-rhode-island-crew/">What's Up Rhode Island Crew</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-01-14T10:46:34+00:00" >January 14, 2020</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Patti+LaBelle+Returning+to+Mohegan+Sun+May+3&url=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F&via=whats_up_ri">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/&amp;media=https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-scaled.jpeg&description=Patti+LaBelle+Returning+to+Mohegan+Sun+May+3">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Patti LaBelle Returning to Mohegan Sun May 3 %0A%0A https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/&title=Patti LaBelle Returning to Mohegan Sun May 3">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Patti LaBelle Returning to Mohegan Sun May 3&body=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">

        <div class="td-post-featured-image"><figure><a href="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-scaled.jpeg" data-caption="Patti LaBelle"><img width="696" height="868" class="entry-thumb td-modal-image" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-696x868.jpeg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-696x868.jpeg 696w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-481x600.jpeg 481w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-120x150.jpeg 120w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-768x958.jpeg 768w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-1231x1536.jpeg 1231w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-1642x2048.jpeg 1642w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-1068x1332.jpeg 1068w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-337x420.jpeg 337w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="patti"/></a><figcaption class="wp-caption-text">Patti LaBelle</figcaption></figure></div>
        <div class="td-a-rec td-a-rec-id-content_top  td_uid_3_5e1de26179faa_rand td_block_template_8"><div class="td-all-devices">
    <div class="whats-manual-1" id="whats-1829185969"><p><a href="https://whatsuprhodeisland.com/advertise-with-us/"><img class="aligncenter wp-image-1161 size-full" src="https://whatsuprhodeisland.com/wp-content/uploads/2017/09/advertise-with-us-button-fotter.png" alt="" width="728" height="90" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2017/09/advertise-with-us-button-fotter.png 728w, https://whatsuprhodeisland.com/wp-content/uploads/2017/09/advertise-with-us-button-fotter-300x37.png 300w" sizes="(max-width: 728px) 100vw, 728px" /></a></p>
</div>
</div></div>
<p>UNCASVILLE, CT (January 14, 2020) – Icon, legend and superstar Patti LaBelle returns to <a rel="noreferrer noopener" target="_blank" href="https://u7061146.ct.sendgrid.net/wf/click?upn=G62jSYfZdO-2F12d8lSllQB2WWqahe67opabwWzE0UHVF-2BcSNroNDAx87jKCBQqbkMhBwyXUEFTxcjW68gRqBYa9UAhE43Fs1EzZUPtVy-2BfWbj67vzgF0wRog3cnUXp12QRbS1CD-2FsPjgEqX6U0ro8wPH3jXHy1Bq8JB-2FH7H856j0BhzpslJAW3W720QiOd5k4QYrZ0-2FshBl62Q4zohyV-2Bk7Rjix44yMAjj3tyYzr-2BcEQ-3D_KSS35fW2e1lz3dzEr6Chvn6se2mZ0zWIWNepILHDw24syL2uot1scrPoDny1-2Fl4JLWwkbm9O8sDxfDz3Q8okJO0BSii99-2FAR-2BX749JE37z5oceNU-2FFUjQSpYp-2BIFNiE3t2rZTZScKeF3G3S1Nf151vWfOL-2F4y61RQPHoXlEXUOLukTN6ARu0Yea3UNqqVaKkP-2FJIBp-2BSm9ec1PUJN-2F4EAMJejzliPi1AB74Mj-2FB-2BMqOhuc7Otyzja-2B5EN7p3zY96evYZrLVJWm0c5XeOe4fqBcXImXqg3Pgm1fsNXb0wiEISzz2v7gNcjDUkXtRLiouMtVOouGUJXbp-2B4bu-2B7YFSKg-3D-3D">Mohegan Sun Arena</a> on Sunday, May 3rd at 7:30pm.  She&#8217;ll bring classic Rhythm and Blues renditions, Pop standards and spiritual sonnets that have created the unique platform of versatility that she is known and revered for.</p>



<p>Tickets are $39.00, $29.00 and $19.00 and go on sale Friday, January 17th at 10:00am through Ticketmaster. Ticketmaster customers may log on to&nbsp;<a rel="noreferrer noopener" target="_blank" href="https://u7061146.ct.sendgrid.net/wf/click?upn=84Em28S1K9SvtzcUtu04EnNSpiLgP2U-2FVMAoxljnHPhlc6y2vOCTA1mVo3HSxuGF_KSS35fW2e1lz3dzEr6Chvn6se2mZ0zWIWNepILHDw24syL2uot1scrPoDny1-2Fl4JLWwkbm9O8sDxfDz3Q8okJO0BSii99-2FAR-2BX749JE37z5oceNU-2FFUjQSpYp-2BIFNiE3t2rZTZScKeF3G3S1Nf151vWfOL-2F4y61RQPHoXlEXUOLukTN6ARu0Yea3UNqqVaKkhwVsFn2tLWgAcBn2wrjMaAuYbxI5fdwycq2YThEcgNMYRMP0JBjMWVpGepg7Pg9nHbMwqIfpuzAPjkgt5JU6gKTU3bGOd-2BPdNM-2Bpn766oEzJnBckkiR9XtkKRcgfTcypRYnWjlp3PcOu1ZVnfPjdIw-3D-3D">ticketmaster.com</a>.&nbsp;Tickets will also be available at the Mohegan Sun Box Office beginning Saturday, January 18th at 10:00am, subject to availability.</p>



<p>It’s a small wonder that Patti has time for anything else in between recording and touring, but she makes time and the world is oh so happy that she does! She has written six books, <em>Don’t Block the Blessings</em>, <em>LaBelle Cuisine: Recipes to Sing About</em>, <em>Patti’s Pearls</em>, <em>Patti LaBelle’s Lite Cuisine</em>, <em>Recipes for the Good Life</em> and her most recent, <em>Desserts LaBelle</em>. Several years ago, she introduced <em>Patti’s</em> <em>Good Life</em>, a successful food line that includes a variety of pies, cobblers and cakes, and is available at Walmart stores. Also, she has starred in a highly rated cooking show, <em>Patti LaBelle&#8217;s Place</em>, on the Cooking Channel. In 2017, Patti released her first Jazz album, <em>Bel Hommage</em>, and a holiday album, <em>Patti LaBelle and Friends &#8211; Home for the Holidays</em>, on her own record label, GPE Records. And most recently, Patti expanded the <em>Patti’s Good Life</em> line to include frozen comfort foods such as macaroni &amp; cheese, greens, beef brisket and cornbread. </p>



<p>World-renowned for her dynamic career as an entertainer and entrepreneurial success, Patti’s work as a humanitarian is just as legendary. She remains an advocate for adoption, diabetes, cancer, HIV / AIDS and many other causes and non-profit initiatives. While she has reached the heights of success throughout her 50-plus year career, Patti has also endured and survived personal strife. Within a 10-year period, she lost her mother, three sisters and best friend to diabetes and cancer. In 1994, she was diagnosed with diabetes and shortly thereafter became a spokesperson for the American Diabetes Association. </p>



<div class="td-a-rec td-a-rec-id-content_inline  td_uid_2_5e1de261775b3_rand td_block_template_8"><span class="td-adspot-title">- Advertisement - </span><div class="td-all-devices">
    <div class="whats-manual-300" id="whats-1380826279"><p><a href="http://www.chriselectricltd.com"><img class="aligncenter size-full wp-image-1184" src="https://whatsuprhodeisland.com/wp-content/uploads/2017/09/chriselectricfinal2.jpg" alt="" width="300" height="250"></a></p>
</div>
</div></div><p>The same motivation that had Patricia Louise Holte blossom from a choir member to lead vocalist for Patti LaBelle &amp; The Bluebelles and later Labelle, to a solo artist is the same energy that keeps her fire burning at 75 years young. “Each year I grow, and that’s a blessing from God. I do what I can do.  I do what I feel God has given me the energy to do, so I just go out there and I do it…It’s not about making money because I don’t need money, but I need to sing. With a voice or without, I’ve got to get on that stage.” And the world is thankful that Patti’s voice sounds so good to our ears.</p>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_4_5e1de2617bc02_rand td_block_template_8"><hr />
<div id="mc_embed_signup">
<form id="mc-embedded-subscribe-form" class="validate" action="https://whatsupnewp.us20.list-manage.com/subscribe/post?u=322b278a200dd604efc0a9d50&amp;id=8a12f7e929" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="clear" style="text-align: center;"><a href="https://whatsuprhodeisland.com/sign-up-for-our-email-newsletters/"><strong>Sign up for our email newsletter, </strong></a></div>
<div class="clear" style="text-align: center;"><strong><a href="https://whatsuprhodeisland.com/sign-up-for-our-email-newsletters/">you&#8217;ll never miss another story from What&#8217;s Up Rhode Island</a></strong></div>
</div>
</form>
</div>
<p><!--End mc_embed_signup--></p>
</div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://whatsuprhodeisland.com/tag/mohegan-sun/">Mohegan Sun</a></li><li><a href="https://whatsuprhodeisland.com/tag/patti-labelle/">Patti LaBelle</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Patti+LaBelle+Returning+to+Mohegan+Sun+May+3&url=https%3A%2F%2Fwhatsuprhodeisland.com%2F2020%2F01%2Fpatti-labelle-returning-to-mohegan-sun-may-3%2F&via=whats_up_ri">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/&amp;media=https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-scaled.jpeg&description=Patti+LaBelle+Returning+to+Mohegan+Sun+May+3">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Patti LaBelle Returning to Mohegan Sun May 3 %0A%0A https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/&title=Patti LaBelle Returning to Mohegan Sun May 3">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Patti LaBelle Returning to Mohegan Sun May 3&body=https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://whatsuprhodeisland.com/2020/01/legislative-news-jan-13-state-of-the-state-address-arming-campus-police-school-district-raising-funds/">Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><a href="https://whatsuprhodeisland.com/author/whats-up-rhode-island-crew/"><img alt='' src='https://secure.gravatar.com/avatar/ea81fa7c49f1635e4e802a545eaa445e?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ea81fa7c49f1635e4e802a545eaa445e?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://whatsuprhodeisland.com/author/whats-up-rhode-island-crew/">What's Up Rhode Island Crew</a></span></div><div class="td-author-url"><a href="http://www.whatsuprhodeisland.com">http://www.whatsuprhodeisland.com</a></div><div class="td-author-description">The latest from the What's Up Rhode Island Crew. Have a question or something to share? Email Info@whatsuprhodeisland.com.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="What&#039;s Up Rhode Island Crew"></span><meta itemprop="datePublished" content="2020-01-14T10:46:34+00:00"><meta itemprop="dateModified" content="2020-01-14T10:46:36-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/"></span><meta itemprop="name" content="What&#039;s Up Rhode Island"></span><meta itemprop="headline " content="Patti LaBelle Returning to Mohegan Sun May 3"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-scaled.jpeg"><meta itemprop="width" content="2052"><meta itemprop="height" content="2560"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_5_5e1de2617f08b_rand td_with_ajax_pagination td-pb-border-top td_block_template_8"  data-td-block-uid="td_uid_5_5e1de2617f08b" ><script>var block_td_uid_5_5e1de2617f08b = new tdBlock();
block_td_uid_5_5e1de2617f08b.id = "td_uid_5_5e1de2617f08b";
block_td_uid_5_5e1de2617f08b.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_5_5e1de2617f08b_rand","td_column_number":3,"live_filter_cur_post_id":12150,"live_filter_cur_post_author":"19","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_5_5e1de2617f08b_rand","tdc_css_class_style":"td_uid_5_5e1de2617f08b_rand_style"}';
block_td_uid_5_5e1de2617f08b.td_column_number = "3";
block_td_uid_5_5e1de2617f08b.block_type = "td_block_related_posts";
block_td_uid_5_5e1de2617f08b.post_count = "6";
block_td_uid_5_5e1de2617f08b.found_posts = "871";
block_td_uid_5_5e1de2617f08b.header_color = "";
block_td_uid_5_5e1de2617f08b.ajax_pagination_infinite_stop = "";
block_td_uid_5_5e1de2617f08b.max_num_pages = "146";
tdBlocksArray.push(block_td_uid_5_5e1de2617f08b);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_6_5e1de2618875b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_5_5e1de2617f08b" href="#">RELATED ARTICLES</a><a id="td_uid_7_5e1de26188765" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_5_5e1de2617f08b" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_5_5e1de2617f08b class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/matchbox-20-the-wallflowers-coming-to-xfinity-center-mohegan-sun-in-july/" rel="bookmark" class="td-image-wrap" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July"><img width="218" height="150" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-218x150.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July"/></a></div>                <a href="https://whatsuprhodeisland.com/category/entertainment-music/" class="td-post-category">Entertainment &amp; Music</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/matchbox-20-the-wallflowers-coming-to-xfinity-center-mohegan-sun-in-july/" rel="bookmark" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July">Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/newport-folk-festival-2020-lineup-announcements/" rel="bookmark" class="td-image-wrap" title="Newport Folk Festival: 2020 lineup announcements"><img width="218" height="145" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2018/07/5Y9A5965.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2018/07/5Y9A5965.jpg 5472w, https://whatsuprhodeisland.com/wp-content/uploads/2018/07/5Y9A5965-300x200.jpg 300w, https://whatsuprhodeisland.com/wp-content/uploads/2018/07/5Y9A5965-768x512.jpg 768w, https://whatsuprhodeisland.com/wp-content/uploads/2018/07/5Y9A5965-1024x683.jpg 1024w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Newport Folk Festival: 2020 lineup announcements"/></a></div>                <a href="https://whatsuprhodeisland.com/category/entertainment-music/" class="td-post-category">Entertainment &amp; Music</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/newport-folk-festival-2020-lineup-announcements/" rel="bookmark" title="Newport Folk Festival: 2020 lineup announcements">Newport Folk Festival: 2020 lineup announcements</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/the-charlie-daniels-band-the-marshall-tucker-band-coming-to-indian-ranch-on-august-30th/" rel="bookmark" class="td-image-wrap" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th"><img width="218" height="150" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-218x150.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th"/></a></div>                <a href="https://whatsuprhodeisland.com/category/entertainment-music/" class="td-post-category">Entertainment &amp; Music</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/the-charlie-daniels-band-the-marshall-tucker-band-coming-to-indian-ranch-on-august-30th/" rel="bookmark" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th">The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsupnewp.com/2020/01/jamestown-arts-center-names-maureen-coleman-new-executive-director/#new_tab" rel="bookmark" class="td-image-wrap" title="Jamestown Arts Center names new Executive Director"><img width="218" height="150" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/IMG_9615-218x150.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/IMG_9615-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/IMG_9615-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Jamestown Arts Center names new Executive Director"/></a></div>                <a href="https://whatsuprhodeisland.com/category/arts/" class="td-post-category">Arts &amp; Culture</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsupnewp.com/2020/01/jamestown-arts-center-names-maureen-coleman-new-executive-director/#new_tab" rel="bookmark" title="Jamestown Arts Center names new Executive Director">Jamestown Arts Center names new Executive Director</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/six-picks-music-the-best-in-local-music-this-weekend-jan-10-12/" rel="bookmark" class="td-image-wrap" title="Six Picks Music: The Best in Local Music This Weekend (Jan. 10-12)"><img width="218" height="150" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2019/07/PromoShot2HRIC-byDavidLeeBlack-218x150.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2019/07/PromoShot2HRIC-byDavidLeeBlack-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2019/07/PromoShot2HRIC-byDavidLeeBlack-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Six Picks Music: The Best in Local Music This Weekend (Jan. 10-12)"/></a></div>                <a href="https://whatsuprhodeisland.com/category/arts/" class="td-post-category">Arts &amp; Culture</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/six-picks-music-the-best-in-local-music-this-weekend-jan-10-12/" rel="bookmark" title="Six Picks Music: The Best in Local Music This Weekend (Jan. 10-12)">Six Picks Music: The Best in Local Music This Weekend (Jan. 10-12)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/preview-2020-winter-and-spring-programs-at-providences-lippitt-house-museum/" rel="bookmark" class="td-image-wrap" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum"><img width="218" height="150" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-218x150.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum"/></a></div>                <a href="https://whatsuprhodeisland.com/category/arts/" class="td-post-category">Arts &amp; Culture</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/preview-2020-winter-and-spring-programs-at-providences-lippitt-house-museum/" rel="bookmark" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum">Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_5_5e1de2617f08b" data-td_block_id="td_uid_5_5e1de2617f08b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_5_5e1de2617f08b" data-td_block_id="td_uid_5_5e1de2617f08b"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
            </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                <aside class="td_block_template_8 widget whats-widget"><p><a href="https://www.durisstudios.com/shop/hand-blown-glass-and-diamond-pendant"><img class="aligncenter size-full wp-image-12012" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300.jpg" alt="" width="300" height="300" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300.jpg 300w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300-150x150.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
</aside><div class="td_block_wrap td_block_1 td_block_widget td_uid_8_5e1de26191792_rand td-pb-border-top td_block_template_8 td-column-1"  data-td-block-uid="td_uid_8_5e1de26191792" ><script>var block_td_uid_8_5e1de26191792 = new tdBlock();
block_td_uid_8_5e1de26191792.id = "td_uid_8_5e1de26191792";
block_td_uid_8_5e1de26191792.atts = '{"custom_title":"The Latest","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_8_5e1de26191792_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_8_5e1de26191792_rand","tdc_css_class_style":"td_uid_8_5e1de26191792_rand_style"}';
block_td_uid_8_5e1de26191792.td_column_number = "1";
block_td_uid_8_5e1de26191792.block_type = "td_block_1";
block_td_uid_8_5e1de26191792.post_count = "5";
block_td_uid_8_5e1de26191792.found_posts = "1608";
block_td_uid_8_5e1de26191792.header_color = "";
block_td_uid_8_5e1de26191792.ajax_pagination_infinite_stop = "";
block_td_uid_8_5e1de26191792.max_num_pages = "322";
tdBlocksArray.push(block_td_uid_8_5e1de26191792);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>The Latest</span></h4></div><div id=td_uid_8_5e1de26191792 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/" rel="bookmark" class="td-image-wrap" title="Patti LaBelle Returning to Mohegan Sun May 3"><img width="324" height="235" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/patti-324x235.jpeg" alt="" title="Patti LaBelle Returning to Mohegan Sun May 3"/></a></div>                <a href="https://whatsuprhodeisland.com/category/arts/" class="td-post-category">Arts &amp; Culture</a>            </div>

            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/" rel="bookmark" title="Patti LaBelle Returning to Mohegan Sun May 3">Patti LaBelle Returning to Mohegan Sun May 3</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://whatsuprhodeisland.com/author/whats-up-rhode-island-crew/">What's Up Rhode Island Crew</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-14T10:46:34+00:00" >January 14, 2020</time></span>                <div class="td-module-comments"><a href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/#respond">0</a></div>            </div>

            <div class="td-excerpt">
                
UNCASVILLE, CT (January 14, 2020) – Icon, legend and superstar Patti LaBelle returns to Mohegan Sun Arena on Sunday, May 3rd at 7:30pm.  She&#039;ll bring...            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/legislative-news-jan-13-state-of-the-state-address-arming-campus-police-school-district-raising-funds/" rel="bookmark" class="td-image-wrap" title="Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-225x160.jpg 225w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/legislative-news-jan-13-state-of-the-state-address-arming-campus-police-school-district-raising-funds/" rel="bookmark" title="Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds">Legislative News &#8211; Jan. 13: State of the State Address; Arming...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-14T05:49:10+00:00" >January 14, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/" rel="bookmark" class="td-image-wrap" title="Governor Raimondo will deliver State of the State Address on Tuesday"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-218x150.jpg 218w, https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-225x160.jpg 225w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Governor Raimondo will deliver State of the State Address on Tuesday"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/" rel="bookmark" title="Governor Raimondo will deliver State of the State Address on Tuesday">Governor Raimondo will deliver State of the State Address on Tuesday</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-13T14:56:07+00:00" >January 13, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/rhode-island-general-treasurer-an-additional-23-million-in-new-missing-money-is-waiting-to-be-claimed-by-rhode-islanders/" rel="bookmark" class="td-image-wrap" title="Rhode Island General Treasurer: An additional $23 million in new Missing Money is waiting to be claimed by Rhode Islanders"><img width="100" height="67" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/money.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2017/05/money.jpg 948w, https://whatsuprhodeisland.com/wp-content/uploads/2017/05/money-300x200.jpg 300w, https://whatsuprhodeisland.com/wp-content/uploads/2017/05/money-768x512.jpg 768w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Rhode Island General Treasurer: An additional $23 million in new Missing Money is waiting to be claimed by Rhode Islanders"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/rhode-island-general-treasurer-an-additional-23-million-in-new-missing-money-is-waiting-to-be-claimed-by-rhode-islanders/" rel="bookmark" title="Rhode Island General Treasurer: An additional $23 million in new Missing Money is waiting to be claimed by Rhode Islanders">Rhode Island General Treasurer: An additional $23 million in new Missing...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-13T14:51:09+00:00" >January 13, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/matchbox-20-the-wallflowers-coming-to-xfinity-center-mohegan-sun-in-july/" rel="bookmark" class="td-image-wrap" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/unnamed-49-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/matchbox-20-the-wallflowers-coming-to-xfinity-center-mohegan-sun-in-july/" rel="bookmark" title="Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July">Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-13T10:28:15+00:00" >January 13, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="widget_text td_block_template_8 widget widget_custom_html"><div class="textwidget custom-html-widget"><hr />

<span style="color: #111111; font-family: Roboto, sans-serif; font-size: 27px;">Sign up for our free newsletter, you’ll never miss another story from What’s Up Rhode Island</span>
<div id="mc_embed_signup"><form id="mc-embedded-subscribe-form" class="validate" action="https://whatsupnewp.us20.list-manage.com/subscribe/post?u=322b278a200dd604efc0a9d50&amp;id=8a12f7e929" method="post" name="mc-embedded-subscribe-form" novalidate="" target="_blank">
<div id="mc_embed_signup_scroll">
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group"><label for="mce-EMAIL">Email Address <span class="asterisk">*</span>
</label>
<input id="mce-EMAIL" class="required email" name="EMAIL" type="email" value="" /></div>
<div class="mc-field-group"><label for="mce-FNAME">First Name </label>
<input id="mce-FNAME" class="" name="FNAME" type="text" value="" /></div>
<div class="mc-field-group"><label for="mce-LNAME">Last Name </label>
<input id="mce-LNAME" class="" name="LNAME" type="text" value="" /></div>
<div id="mce-responses" class="clear">
<div id="mce-error-response" class="response" style="display: none;"></div>
<div id="mce-success-response" class="response" style="display: none;"></div>
</div>
<!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input tabindex="-1" name="b_322b278a200dd604efc0a9d50_8a12f7e929" type="text" value="" /></div>
<div class="clear"><input id="mc-embedded-subscribe" class="button" name="subscribe" type="submit" value="Subscribe" /></div>
</div>
</form></div>
<!--End mc_embed_signup--></div></aside><aside class="td_block_template_8 widget whats-widget"><p><a href="http://www.chriselectricltd.com"><img class="aligncenter size-full wp-image-1184" src="https://whatsuprhodeisland.com/wp-content/uploads/2017/09/chriselectricfinal2.jpg" alt="" width="300" height="250"></a></p>
</aside><aside class="td_block_template_8 widget whats-widget"><p><a href="https://www.durisstudios.com/shop/hand-blown-glass-and-diamond-pendant"><img class="aligncenter size-full wp-image-12012" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300.jpg" alt="" width="300" height="300" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300.jpg 300w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisBlue2018GlassPD300x300-150x150.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
</aside><div class="td_block_wrap td_block_1 td_block_widget td_uid_9_5e1de261a089b_rand td-pb-border-top td_block_template_8 td-column-1"  data-td-block-uid="td_uid_9_5e1de261a089b" ><script>var block_td_uid_9_5e1de261a089b = new tdBlock();
block_td_uid_9_5e1de261a089b.id = "td_uid_9_5e1de261a089b";
block_td_uid_9_5e1de261a089b.atts = '{"custom_title":"More From WURI","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m4_tl":"","m4_el":"","m6_tl":"","limit":"5","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_7_day","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_9_5e1de261a089b_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m4f_title_font_header":"","m4f_title_font_title":"Article title","m4f_title_font_settings":"","m4f_title_font_family":"","m4f_title_font_size":"","m4f_title_font_line_height":"","m4f_title_font_style":"","m4f_title_font_weight":"","m4f_title_font_transform":"","m4f_title_font_spacing":"","m4f_title_":"","m4f_cat_font_title":"Article category tag","m4f_cat_font_settings":"","m4f_cat_font_family":"","m4f_cat_font_size":"","m4f_cat_font_line_height":"","m4f_cat_font_style":"","m4f_cat_font_weight":"","m4f_cat_font_transform":"","m4f_cat_font_spacing":"","m4f_cat_":"","m4f_meta_font_title":"Article meta info","m4f_meta_font_settings":"","m4f_meta_font_family":"","m4f_meta_font_size":"","m4f_meta_font_line_height":"","m4f_meta_font_style":"","m4f_meta_font_weight":"","m4f_meta_font_transform":"","m4f_meta_font_spacing":"","m4f_meta_":"","m4f_ex_font_title":"Article excerpt","m4f_ex_font_settings":"","m4f_ex_font_family":"","m4f_ex_font_size":"","m4f_ex_font_line_height":"","m4f_ex_font_style":"","m4f_ex_font_weight":"","m4f_ex_font_transform":"","m4f_ex_font_spacing":"","m4f_ex_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_9_5e1de261a089b_rand","tdc_css_class_style":"td_uid_9_5e1de261a089b_rand_style"}';
block_td_uid_9_5e1de261a089b.td_column_number = "1";
block_td_uid_9_5e1de261a089b.block_type = "td_block_1";
block_td_uid_9_5e1de261a089b.post_count = "5";
block_td_uid_9_5e1de261a089b.found_posts = "32";
block_td_uid_9_5e1de261a089b.header_color = "";
block_td_uid_9_5e1de261a089b.ajax_pagination_infinite_stop = "";
block_td_uid_9_5e1de261a089b.max_num_pages = "7";
tdBlocksArray.push(block_td_uid_9_5e1de261a089b);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>More From WURI</span></h4></div><div id=td_uid_9_5e1de261a089b class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_4 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/" rel="bookmark" class="td-image-wrap" title="Governor Raimondo will deliver State of the State Address on Tuesday"><img width="225" height="225" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo.jpg 225w, https://whatsuprhodeisland.com/wp-content/uploads/2019/01/raimondo-150x150.jpg 150w" sizes="(max-width: 225px) 100vw, 225px" alt="" title="Governor Raimondo will deliver State of the State Address on Tuesday"/></a></div>                <a href="https://whatsuprhodeisland.com/category/government-politics/" class="td-post-category">Government &amp; Politics</a>            </div>

            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/" rel="bookmark" title="Governor Raimondo will deliver State of the State Address on Tuesday">Governor Raimondo will deliver State of the State Address on Tuesday</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://whatsuprhodeisland.com/author/ryanbelmore/">Ryan Belmore</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-13T14:56:07+00:00" >January 13, 2020</time></span>                <div class="td-module-comments"><a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/#respond">0</a></div>            </div>

            <div class="td-excerpt">
                
 A joint session of the General Assembly will receive Governor Raimondo’s State of the State Address at 7 p.m. Tuesday, Jan....            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/the-charlie-daniels-band-the-marshall-tucker-band-coming-to-indian-ranch-on-august-30th/" rel="bookmark" class="td-image-wrap" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/get-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/the-charlie-daniels-band-the-marshall-tucker-band-coming-to-indian-ranch-on-august-30th/" rel="bookmark" title="The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th">The Charlie Daniels Band, The Marshall Tucker Band coming to Indian...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-13T08:36:35+00:00" >January 13, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/common-cause-focuses-on-the-2020-census-and-changing-how-the-state-draws-legislative-and-congressional-district-lines/" rel="bookmark" class="td-image-wrap" title="Common Cause focuses on the 2020 Census and changing how the state draws Legislative and Congressional district lines"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2018/11/NM-Statehouse-20_720af2ae-5056-a36a-09964a4163a4b193-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2018/11/NM-Statehouse-20_720af2ae-5056-a36a-09964a4163a4b193-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2018/11/NM-Statehouse-20_720af2ae-5056-a36a-09964a4163a4b193-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Common Cause focuses on the 2020 Census and changing how the state draws Legislative and Congressional district lines"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/common-cause-focuses-on-the-2020-census-and-changing-how-the-state-draws-legislative-and-congressional-district-lines/" rel="bookmark" title="Common Cause focuses on the 2020 Census and changing how the state draws Legislative and Congressional district lines">Common Cause focuses on the 2020 Census and changing how the...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-12T16:12:38+00:00" >January 12, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsupnewp.com/2020/01/preservation-society-of-newport-country-newport-mansions-exceed-1-million-tours-in-2019/#new_tab" rel="bookmark" class="td-image-wrap" title="Preservation Society of Newport Country: Newport Mansions exceed 1 million tours in 2019"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Marble-House-visitors-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Marble-House-visitors-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Marble-House-visitors-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Preservation Society of Newport Country: Newport Mansions exceed 1 million tours in 2019"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsupnewp.com/2020/01/preservation-society-of-newport-country-newport-mansions-exceed-1-million-tours-in-2019/#new_tab" rel="bookmark" title="Preservation Society of Newport Country: Newport Mansions exceed 1 million tours in 2019">Preservation Society of Newport Country: Newport Mansions exceed 1 million tours...</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-08T05:35:00+00:00" >January 8, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://whatsuprhodeisland.com/2020/01/preview-2020-winter-and-spring-programs-at-providences-lippitt-house-museum/" rel="bookmark" class="td-image-wrap" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum"><img width="100" height="70" class="entry-thumb" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-100x70.jpg" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-100x70.jpg 100w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/Annotation-2020-01-10-085449-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://whatsuprhodeisland.com/2020/01/preview-2020-winter-and-spring-programs-at-providences-lippitt-house-museum/" rel="bookmark" title="Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum">Preview: 2020 Winter and Spring programs at Providence’s Lippitt House Museum</a></h3>            <div class="td-module-meta-info">
                                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-10T08:55:26+00:00" >January 10, 2020</time></span>                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_8 widget whats-widget"><p><a href="https://www.durisstudios.com/shop/compass-rose-pendant"><img class="aligncenter size-full wp-image-12010" src="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisJan2300x300.jpg" alt="" width="300" height="300" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisJan2300x300.jpg 300w, https://whatsuprhodeisland.com/wp-content/uploads/2020/01/WhatsUpNewpDurisJan2300x300-150x150.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
</aside><aside class="td_block_template_8 widget whats-widget"><p><a href="http://www.redboneevents.com"><img class="aligncenter size-full wp-image-10615" src="https://whatsuprhodeisland.com/wp-content/uploads/2019/11/Redbone300_300B.png" alt="" width="300" height="300" srcset="https://whatsuprhodeisland.com/wp-content/uploads/2019/11/Redbone300_300B.png 300w, https://whatsuprhodeisland.com/wp-content/uploads/2019/11/Redbone300_300B-150x150.png 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></p>
</aside>		<aside class="td_block_template_8 widget widget_recent_entries">		<h4 class="td-block-title"><span>The Latest</span></h4>		<ul>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/patti-labelle-returning-to-mohegan-sun-may-3/" aria-current="page">Patti LaBelle Returning to Mohegan Sun May 3</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/legislative-news-jan-13-state-of-the-state-address-arming-campus-police-school-district-raising-funds/">Legislative News &#8211; Jan. 13: State of the State Address; Arming Campus Police; School District raising funds</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/governor-raimondo-will-deliver-state-of-the-state-address-on-tuesday/">Governor Raimondo will deliver State of the State Address on Tuesday</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/rhode-island-general-treasurer-an-additional-23-million-in-new-missing-money-is-waiting-to-be-claimed-by-rhode-islanders/">Rhode Island General Treasurer: An additional $23 million in new Missing Money is waiting to be claimed by Rhode Islanders</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/matchbox-20-the-wallflowers-coming-to-xfinity-center-mohegan-sun-in-july/">Matchbox 20, The Wallflowers coming to Xfinity Center, Mohegan Sun in July</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/newport-folk-festival-2020-lineup-announcements/">Newport Folk Festival: 2020 lineup announcements</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/the-charlie-daniels-band-the-marshall-tucker-band-coming-to-indian-ranch-on-august-30th/">The Charlie Daniels Band, The Marshall Tucker Band coming to Indian Ranch on August 30th</a>
									</li>
											<li>
					<a href="https://whatsupnewp.com/2020/01/whats-up-newp-to-host-local-news-discussion-on-january-30th/#new_tab">What’s Up Newp to host Local News Discussion on January 30th</a>
									</li>
											<li>
					<a href="https://whatsupnewp.com/2020/01/jamestown-arts-center-names-maureen-coleman-new-executive-director/#new_tab">Jamestown Arts Center names new Executive Director</a>
									</li>
											<li>
					<a href="https://whatsuprhodeisland.com/2020/01/common-cause-focuses-on-the-2020-census-and-changing-how-the-state-draws-legislative-and-congressional-district-lines/">Common Cause focuses on the 2020 Census and changing how the state draws Legislative and Congressional district lines</a>
									</li>
					</ul>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->


    <div class="td-main-content-wrap td-footer-instagram-container td-container-wrap ">
        
        <div class="td-instagram-user">
            <h4 class="td-footer-instagram-title">
                Follow us on Instagram                <a class="td-footer-instagram-user-link" href="https://www.instagram.com/whatsuprhodeisland" target="_blank">@whatsuprhodeisland</a>
            </h4>
        </div>

        <div class="td_block_wrap td_block_instagram td_uid_10_5e1de261b9205_rand td-pb-border-top td_block_template_8"  data-td-block-uid="td_uid_10_5e1de261b9205" ><div class="td-block-title-wrap"></div><div id=td_uid_10_5e1de261b9205 class="td-instagram-wrap td_block_inner td-column-1"><!-- td instagram source: instagram_cache -->        <!-- header section -->
        
        <!-- user shared images -->
                    <div class="td-instagram-main td-images-on-row-3">
                                        <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B6yrErGn49j" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-lax3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c0.180.1440.1440a/s640x640/81969185_159610028710588_8322606328678045090_n.jpg?_nc_ht=scontent-lax3-1.cdninstagram.com&_nc_cat=104&_nc_ohc=Dtjf9o2xusoAX-MeGUB&oh=a26b3c6037a9aae68f48e08e45ab62a3&oe=5EA4BACB"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B6yfXHVHAqP" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-lax3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c170.0.684.684a/s640x640/79600284_456643985012268_3999061014553458125_n.jpg?_nc_ht=scontent-lax3-1.cdninstagram.com&_nc_cat=100&_nc_ohc=waVhFhdv4OgAX_d8Yo7&oh=a18198d26a5c32b398bd8dd29441a7d8&oe=5EA698B9"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/B6vtAXHHuO3" target="_blank">
                                <img class="td-instagram-image" src="https://scontent-lax3-1.cdninstagram.com/v/t51.2885-15/sh0.08/e35/c171.0.682.682a/s640x640/78857915_448556692489468_696044402321407071_n.jpg?_nc_ht=scontent-lax3-1.cdninstagram.com&_nc_cat=104&_nc_ohc=EPur3ILcU2QAX_XgqSz&oh=525f689d58d29d30d6eec496e0d6f0ae&oe=5EA0287A"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                    <div class="clearfix"></div>
            </div>
            </div></div> <!-- ./block -->    </div>




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <aside class="td_block_template_8 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget" href="http://www.whatsupnewp.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://whatsuprhodeisland.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://whatsupnewp.com/">The Latest from What&#8217;s Up Newp</a></span></h4><ul><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/salve-regina-university-hosting-blue-innovation-symposium-this-week/'>Salve Regina University hosting Blue Innovation Symposium this week</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/whats-happening-new-and-to-do-in-newport-county-this-week-january-13-20/'>What’s happening, new, and to do in Newport County this week: January 13 – 20</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/agenda-for-newport-school-committee-special-meeting-regular-meeting-on-jan-14/'>Agenda for Newport School Committee Special Meeting, Regular Meeting on Jan. 14</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/jamestown-arts-center-names-maureen-coleman-new-executive-director/'>Jamestown Arts Center names Maureen Coleman new Executive Director</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/2020-newport-folk-festival-lineup-announcements/'>2020 Newport Folk Festival: Lineup announcements</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/whats-up-newp-to-host-local-news-discussion-on-january-30th/'>What’s Up Newp to host Local News Discussion on January 30th</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/agenda-portsmouth-town-council-meeting-jan-13/'>Agenda: Portsmouth Town Council Meeting (Jan. 13)</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/middletown-conservation-commission-meeting-scheduled-for-january-13th-has-been-cancelled/'>Middletown Conservation Commission Meeting scheduled for January 13th has been cancelled</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/obituary-for-david-l-geary/'>Obituary for David L Geary</a></li><li><a class='rsswidget' href='https://whatsupnewp.com/2020/01/obituary-for-joseph-a-joe-savage-jr/'>Obituary for Joseph A. “Joe” Savage Jr.</a></li></ul></aside>            </div>

            <div class="td-pb-span4">
                <aside class="td_block_template_8 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget" href="http://www.whatsupstowe.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://whatsuprhodeisland.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://whatsupstowe.com/">The Latest from What&#8217;s Up Stowe</a></span></h4><ul><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/25-things-to-do-in-stowe-this-week/'>25 things to do in Stowe this week</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/join-the-whats-up-stowe-crew/'>Join the What’s Up Stowe Crew</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/20-things-to-do-in-and-around-stowe-this-weekend/'>20+ things to do in and around Stowe this weekend</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/25-things-to-do-in-and-around-stowe-this-week/'>25+ things to do in and around Stowe this week</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/now-hiring-in-stowe-55-local-job-opportunities-available-right-now/'>Now Hiring in Stowe: 55 local job opportunities available right now</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/vermont-cider-company-to-launch-viva-spritz-in-spring-2020/'>Vermont Cider Company to launch Viva Spritz in Spring 2020</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2020/01/whats-happening-new-and-to-do-in-stowe-this-weekend-jan-3-5/'>What’s happening, new, and to do in Stowe this weekend (Jan. 3 – 5)</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2019/12/whats-happening-new-and-to-do-in-and-around-stowe-this-week-dec-31-jan-6/'>What’s happening, new, and to do in and around Stowe this week (Dec. 31 – Jan. 6)</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2019/12/whats-up-this-week-30-things-to-do-in-and-around-stowe/'>What’s Up This Week: 30+ things to do in and around Stowe</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2019/12/23122800457/'>Peoples bounces Harwood Union in up-and-down tilt</a></li></ul></aside>            </div>

            <div class="td-pb-span4">
                <aside class="td_block_template_8 widget widget_rss"><h4 class="td-block-title"><span><a class="rsswidget" href="http://www.whatsupnewengland.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://whatsuprhodeisland.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://whatsupnewengland.com/">The Latest from What&#8217;s Up New England</a></span></h4><ul><li><a class='rsswidget' href='https://whatsuprhodeisland.com/2019/12/photo-gallery-tedeschi-trucks-band-at-orpheum-theatre/#new_tab'>Photo Gallery: Tedeschi Trucks Band at Orpheum Theatre</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/photo-gallery-mandolin-orange-at-boch-center-shubert-theatre/'>Photo Gallery: Mandolin Orange at Boch Center Shubert Theatre</a></li><li><a class='rsswidget' href='http://whatsupstowe.com/2019/11/vail-resorts-stowe-okemo-and-mount-sunapee-to-celebrate-opening-day-with-first-chair-events/#new_tab'>Stowe, Okemo and Mount Sunapee to celebrate Opening Day with First Chair Events</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/basia-bulat-to-release-are-you-live-on-march-27-will-perform-at-the-sinclair-in-april/'>Basia Bulat to release ‘Are You Live? on March 27, will perform at The Sinclair in April</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/refugee-notable-boston-musicians-to-pay-tribute-to-tom-petty-in-norwood-on-saturday-event-will-raise-money-for-addiction-treatment/'>Refugee, notable Boston musicians to pay tribute to Tom Petty in Norwood on Saturday, event will raise money for addiction treatment</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/the-ballroom-thieves-to-release-unlovely-2020-spring-headline-tour-will-bring-them-to-me-vt-and-ri/'>The Ballroom Thieves to release ‘Unlovely’, 2020 Spring Headline Tour will bring them to ME, VT, and RI</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/ajr-announces-2020-neotheater-world-tour-coming-to-ri-ct-and-me-in-may/'>AJR announces 2020 Neotheater World Tour, coming to RI, CT, and ME in May</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/photo-gallery-dark-star-orchestra-at-lowell-memorial-auditorium-11-16-19/'>Photo Gallery: Dark Star Orchestra at Lowell Memorial Auditorium (11/16/19)</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/colony-house-unveils-new-single-coming-to-brighton-music-hall-in-march/'>Colony House unveils new single, coming to Brighton Music Hall in March</a></li><li><a class='rsswidget' href='http://whatsupnewengland.com/chadwick-stokes-the-pintos-release-self-titled-album-coming-to-holyoke-and-boston-in-december/'>Chadwick Stokes &amp; The Pintos release self-titled album, coming to Holyoke and Boston in December</a></li></ul></aside>            </div>
        </div>
    </div>
<div class="td-footer-bottom-full">
    <div class="td-container">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://whatsuprhodeisland.com/"><img src="https://whatsuprhodeisland.com/wp-content/uploads/2019/10/WUNE-Whats-Up-New-England-5.png" alt="What\'s Up Rhode Island" title="What\'s Up Rhode Island"/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>From the award-winning team behind What's Up Newp, What's Up RhodeIsland is your proper source for what's happening, new, and to do in Rhode Island.<div class="footer-email-wrap">Contact us: <a href="mailto:info@whatsuprhodeisland.com">info@whatsuprhodeisland.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/whatsuprhodeisland/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.instagram.com/whatsuprhodeisland" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://www.twitter.com/whats_up_ri" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-main-container"><ul id="menu-main-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-2715"><a href="https://whatsuprhodeisland.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6697"><a href="https://whatsuprhodeisland.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-11336"><a href="https://whatsuprhodeisland.com/2019/12/school-and-business-closings-in-rhode-island-and-southeastern-massachusetts/">School and Business Closings in Rhode Island and Southeastern Massachusetts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12042"><a href="https://whatsuprhodeisland.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6690"><a href="https://whatsuprhodeisland.com/category/restaurants/">Food &#038; Drink</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12045"><a href="https://whatsuprhodeisland.com/category/government-politics/">Government &#038; Politics</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1642"><a href="https://whatsuprhodeisland.com/events-calendar/">Events Calendar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6692"><a href="https://whatsuprhodeisland.com/category/things-to-do/">Things To Do</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-6684"><a href="https://whatsuprhodeisland.com/category/arts/">Arts &#038; Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-6685"><a href="https://whatsuprhodeisland.com/category/entertainment-music/">Entertainment &#038; Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6689"><a href="https://whatsuprhodeisland.com/category/sports/">Health &#038; Fitness</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6686"><a href="https://whatsuprhodeisland.com/category/entertainment-music/movies/">Movies</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6693"><a href="https://whatsuprhodeisland.com/category/outdoor-recreation/">Outdoor &#038; Recreation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6687"><a href="https://whatsuprhodeisland.com/category/entertainment-music/photo-gallery/">Photo Gallery</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6688"><a href="https://whatsuprhodeisland.com/category/entertainment-music/review/">Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6691"><a href="https://whatsuprhodeisland.com/category/entertainment-music/theatre/">Theatre</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-6698"><a href="https://whatsuprhodeisland.com/category/people-profiles/">People &#038; Profiles</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6699"><a href="https://whatsuprhodeisland.com/category/people-profiles/interview/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6700"><a href="https://whatsuprhodeisland.com/category/people-profiles/podcasts/">Podcasts</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2720"><a href="https://whatsuprhodeisland.com/category/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-7433"><a href="https://whatsuprhodeisland.com/sports/">Sports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-9840"><a href="http://www.whatsuprhodeisland.com">What&#8217;s Up</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9241"><a href="https://whatsuprhodeisland.com/about-whatsuprhodeisland/">About Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9243"><a href="https://whatsuprhodeisland.com/advertise-with-us/">Advertise With Us</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-9242"><a href="https://whatsuprhodeisland.com/sign-up-for-our-email-newsletters/">Sign Up For Our Email Newsletters</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-9245"><a href="http://www.whatsupnewp.com">What&#8217;s Up Newp</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-10584"><a href="http://www.whatsupstowe.com">What&#8217;s Up Stowe</a></li>
</ul>
</li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; 2018-2019 | What's Up Rhode Island | www.whatsuprhodeisland.com                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 9.1 (rara)
        Deploy mode: deploy
        
        uid: 5e1de261d5372
    -->

    <script>
    jQuery(document).ready(function () {
		jQuery.post('https://whatsuprhodeisland.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/whatsuprhodeisland.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.1'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.2.2'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=4dea8d5b26348370b86f315beb853d86'></script>
<script type='text/javascript' src='https://whatsuprhodeisland.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

<!-- JS generated by theme -->

<script>
    

			
				jQuery().ready(function () {
					tdWeather.addItem({"block_uid":"td_top_weather_uid","location":"Providence, US","api_location":"Providence","api_language":"en","api_key":"a8d2e67de2d0a7c8f500c3f79ddb6f5b","today_icon":"clear-sky-d","today_icon_text":"clear sky","today_temp":[2.29999999999999982236431605997495353221893310546875,36.10000000000000142108547152020037174224853515625],"today_humidity":93,"today_wind_speed":[2.100000000000000088817841970012523233890533447265625,1.3000000000000000444089209850062616169452667236328125],"today_min":[1,33.7999999999999971578290569595992565155029296875],"today_max":[3.899999999999999911182158029987476766109466552734375,39],"today_clouds":1,"current_unit":1,"forecast":[{"timestamp":1579014000,"day_name":"Tue","day_temp":[7,45],"owm_day_index":0},{"timestamp":1579046400,"day_name":"Wed","day_temp":[7,45],"owm_day_index":3},{"timestamp":1579132800,"day_name":"Thu","day_temp":[7,44],"owm_day_index":11},{"timestamp":1579219200,"day_name":"Fri","day_temp":[-1,31],"owm_day_index":19},{"timestamp":1579305600,"day_name":"Sat","day_temp":[-3,26],"owm_day_index":27}]});
				});
			
			

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://whatsuprhodeisland.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://whatsuprhodeisland.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5e1de261d5fa1"></textarea>
						<div id="td_live_css_uid_1_5e1de261d5fa1" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5e1de261d5fa1');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5e1de261d5fa1");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>